PHP is among the most commonly used coding languages. It is pretty popular as it is free software, which you can use to set up responsive sites like community sites, online stores or e-learning websites as opposed to static HTML sites. A PHP module must be activated on the web server where a PHP-driven site is hosted so that its source code can be ‘decrypted’. Because there are no license taxes for this type of module and the language itself provides countless options for the applications that you set up, there’re hundreds of millions of PHP websites. In addition, there are lots of open-source PHP-based scripts, which you can use for your sites without the need to have any programming know-how. Considering the fact that there’re several versions of PHP, you must verify that the same exact version that you used while developing your website is activated on the web server too.

PHP 4, PHP 5, PHP 7 and PHP 8 Support in Shared Hosting

With our Linux shared hosting, you will be able to select the PHP version that will be enabled for your shared account, as multiple versions are available on our servers. With only one click of the mouse, you will be able to switch between PHP 4, 5, 7 and whenever a new version is released in the future, we’ll include it in the Hepsia Control Panel without removing the previous ones. Thus, you will be able to host all the websites that you have developed throughout the years. Unlike many other companies, we won’t force you to update such sites, as a script may be out of date, but this does not mean that it is insecure as you may have done modifications to its source code to fix safety loopholes. For your convenience, you will even be able to pick a different version of PHP for each site that you host in your web hosting account.

PHP 4, PHP 5, PHP 7 and PHP 8 Support in Semi-dedicated Servers

Our Linux semi-dedicated plans support multiple versions of PHP, which suggests that you’ll be able to use all the web apps that you have created throughout the years. The Hepsia Control Panel, which comes with each single account, will allow you to enable the required version with just one click. You can select between PHP 4, PHP 5, PHP 7 and PHP 8. If you want to host multiple sites in one and the very same account and they have distinctive requirements relating to the hosting platform, you’ll be able to specify a different version for each of them regardless of which version is enabled for the account itself. This is achievable owing to our custom-built cloud hosting platform, which allows us to run different PHP versions simultaneously. By comparison, most hosting providers normally offer one, sometimes two versions.